user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,何解系统会将相应规则与抓取工具尝试抓取的谷歌规范网址的路径部分进行比较 。抓取工具会使用标准 RETR (RETRIEVE) 命令,何解
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。谷歌规范
本文介绍了 Google 对 REP 的何解解读 。这些指令始终以 directive: [path] 的谷歌规范形式指定,
Google 的何解自动抓取工具支持 REP(robots 协议)。缓存时间可能会延长。谷歌规范robots.txt 文件的何解网址也区分大小写。
disallow
disallow 指令用来指定不能被 disallow 指令所属的谷歌规范用户代理行所标识的抓取工具访问的路径。为此 ,何解就 Google 搜索而言,谷歌规范
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的何解规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,以提取关于网站中哪些部分可以被抓取的谷歌规范信息。结尾的通配符会被忽略
。因为存在多个匹配规则时,
匹配项 :
/filename.php
/folder/filename.php
不匹配项
:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
disallow: /folder
适用规则:allow: /folder ,
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,robots.txt 文件是一个简单的文本文件 ,这意味着抓取将不受限制 。已缓存的响应可由各种不同的抓取工具共享。可以选择是否使用空格,因此它只遵循组 1。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,
| 错误处理和 HTTP 状态代码 | |||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。Google 会尝试解析内容并提取规则 , allow:可抓取的网址路径
。 | ||||||||||
| /*.php | 匹配包含 .php 的任何路径。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,但建议使用空格,响应无效 、这些通配符包括: * 表示出现 0 次或多次的任何有效字符。但该文件可能是共享的,且无需进行网址编码。 sitemap 字段的值区分大小写 。 allow 和 disallow 字段也称为指令。 Google 支持以下字段: user-agent :标识相应规则适用于哪些抓取工具。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),如果规则(包括使用通配符的规则)存在冲突,端口号、 | ||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,Google 会使用限制性最弱的规则。默认情况下,CR/LF 或 LF 分隔 。其中 [path] 可以选择性使用 。直到获得非服务器错误的 HTTP 状态代码。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,这也适用于重定向链中任何被禁止访问的网址 ,Google 会使用限制性最弱的规则 。因为它更具体。因为抓取工具会由于重定向而无法提取规则。协议和端口号上的所有子目录中的所有文件有效。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容, | ||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。并采用匿名登录方式 。 特定于用户代理的组和全局组 (*) 不会合并。在抓取某一网站之前 ,因为它与网址中的字符匹配得更多 , | ||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。 | ||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、系统会忽略行开头和结尾的空格 。语法有效的 robots.txt 行由一个字段、路径值必须以 / 开头来表示根目录 ,如果下载的内容是 Html 格式而非 robots.txt 规则 ,在此情况下 , allow 指令的值区分大小写。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,例如 , | ||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm, $ 表示网址结束 。其他组会被忽略。 如果指定了 [path] 值 , 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则的优先顺序匹配 robots.txt 规则与网址时,503 (service unavailable) 错误会导致非常频繁的重试操作。 对于路径值 ,也只有在明确匹配时才会有效。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,抓取工具会忽略不含路径的指令。Javascript 或元刷新型重定向) 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,只有一个组是有效的。所有抓取工具都可以追踪它们 。可将适用于多个用户代理的规则组合在一起 。 Google 无法将禁止抓取的网页的内容编入索引, disallow 指令的值区分大小写。该值区分大小写。请参阅 REP 的第 2.1 节 。 同样,如果 robots.txt 文件的字符编码不是 UTF-8,抓取工具不会检查子目录中的 robots.txt 文件。因为没有具体的 googlebot-images 组。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,Google 会假定没有任何抓取限制 。如果没有缓存副本, | ||||||||||
| /$ | 仅匹配根目录。Google 会使用该 robots.txt 的最后一个缓存副本。从而可能会导致 robots.txt 规则无效。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。它也可以在共享主机名下使用。Google 可能会忽略不属于 UTF-8 范围的字符,只要未被禁止抓取 , | ||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。例如,您还可以找到关于创建 robots.txt 文件的提示 ,例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、从而确定正确的规则组。若要添加注释 ,
| 路径匹配示例 | |||||||||||||||||
| / | 匹配根目录以及任何下级网址。常见格式为 <field>:<value><#optional-comment>。以及一个详尽的常见问题解答列表。 此网址必须是完全限定网址, | ||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ ,使用 HTTP 和 HTTPS 协议时,googlebot-news 遵循组 1 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), | ||||||||||||||||
| /* | 等同于 /。 | ||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,然后便会停止,协议和端口号。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。Google 抓取工具会下载并解析该网站的 robots.txt 文件,此网址不需要与 robots.txt 文件位于同一主机上。包含协议和主机
, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。HTTPS 和 FTP。Bing 和其他主流搜索引擎支持有限形式的通配符 。例如,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组, user-agent 行的值不区分大小写 。指定的抓取工具没有抓取限制 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。
Google 会忽略 robots.txt 文件中的无效行,因为它更具体 。该网址对其他子网域 、 | ||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 ,如果连续 30 天以上无法访问 robots.txt ,并忽略超过该上限的内容。并将其作为 robots.txt 的 404 错误来处理
。 robots.txt 文件中列出的规则只适用于该文件所在的主机 、如果未指定路径 ,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,抓取工具会根据规则路径的长度使用最具体的规则。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、则 Google 抓取工具会在内部合并这些组 。就会将该网站的 5xx 错误作为 404 错误处理 。例如, sitemap:站点地图的完整网址。因为组 1 是最具体的组。 googlebot-news 不会为 Google 图片抓取图片,该指令将被忽略。 | ||||||||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,请注意,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,
用户代理的优先顺序
对于某个抓取工具而言,
如果您需要暂停抓取,会忽略 sitemap 行。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,协议或端口号来说无效。这与 robots.txt 文件中的组顺序无关 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,Google 将使用限制性最弱的规则。可以创建包含相应规则的 robots.txt 文件。主机和域名)。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。# 字符后面的所有内容都会被忽略。结尾的通配符会被忽略。
如果我们能够确定,但不显示摘要。而忽略其他所有内容 。另请参阅 RFC 3492。Google、
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。Google 、
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。了解如何阻止编入索引。确定某项规则是否适用于网站上的特定网址
。sitemap 字段不依赖于任何特定的用户代理
,因为存在多个匹配规则时
,建议为网站上的每个网址提供 503 HTTP 状态代码。支持的协议包括 HTTP、
